
37

Chapter 2 

ShipConstructor Installations

6.	 You will be presented with the Custom Setup dialog. By default, the client 
installation method installs the necessary components on the current 
workstation for ShipConstructor 2011 to run while accessing project files 
and databases on a remote server. You can add or remove features if you 
want to further customize your install although it is recommended that 
most users leave the default options.

7.	 Click Next. ShipConstructor 2011 is now ready to install. Click Install to 
begin the installation process.

8.	 Once the installer has completed click the Finish button to close the 
installer.



38

ShipConstructor Installation Guide

Activate ShipConstructor Licensing

1.	 To ensure locks are viewable by the License Server plug the Lock(s) into 
the USB port(s) of the computer for hosting the License Server.

2.	 On the License Server computer, go to your Start menu and choose All 
Programs->ShipConstructor Licensing and click on LockView to open 
the LockView dialog. Ensure that the locks can be viewed. 

Note: If you receive the message, “Unable to View Lock”, contact 
ShipConstructor Software Inc. for technical support.
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3.	 On the License Server computer, go to the Start menu and choose All 
Programs->ShipConstructor Licensing and click on License Monitor.

4.	  In the Server textbox select (Local Computer) and click Refresh. The 
Locks should appear below in the Locks Attached to the Server area. The 
license information should appear below that in the Licensed Module List.

Note: If the License Monitor is unable to see your lock you may 
need to start the ShipConstructor License Server service.

5.	 Click the Close button to close the License Server Monitor once you have 
varified that it is connecting to the lock properly.

6.	 To ensure licenses are viewable by the ShipConstructor Client, on the 
computer hosting the ShipConstructor Client go to your Start menu and 
choose All Programs->ShipConstructor Licensing and click on License 
Monitor. 
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7.	 In the Server textbox, enter the IP address or the name of the license 
server and click Refresh. If the License Monitor can connect to the lock it 
will display it in the Locks Attached to Server area and you will see a list of 
modules on the lock in the Licensed Module List.

8.	 Once you have varified that the client can see the License Server, click 
Close to close the License Monitor window.

9.	 To complete the process you will need to create a new project in 
ShipConstructor. Go to your Start menu and choose All Programs-
>ShipConstructor 2011 and click on ShipConstructor 2011 to launch the 
program.
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10.	 From the ribbon bar choose New Project. The New ShipConstructor 
Project dialog will open.

11.	 Click on the ... button next to the Project Folder text box then choose a 
folder to store your project in.  This can be on your computer or another 
computer on your network.

12.	 For the Project Server choose the machine on your network that has your 
SQL server installed. This will be listed in the format <Machine Name>\
SHIPCON.
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13.	 Under Template Project(s) put a checkmark in the Use the same 
template for all areas.

14.	 Under the .PRO or .XML Template File heading, click on the ... button 
beside Users, Settings & Ranks. Then choose MetricTemplate or 
ImperialTemplate from the dialog box. Click Open.
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15.	 After a few seconds you should see that all of the templates have been 
populated with the path and template file that you just chose.

16.	 In the User Name text box in the Administrator Login section, enter 
ShipConstructor. Then, in the Password text box, enter the password that 
you used for this user during installation.

17.	 Click OK to create the project.  The project creation will take several 
minutes to complete.

18.	 Once the New Project Created dialog box pops up press OK to close it.
19.	 You will now need to connect to project that you just created. Click on 

the Navigator button in the ribbon to bring up the Register Project 
window.
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20.	 Click on the newly created project and enter ShipConstructor for the User 
Name. Then enter your password for the ShipConstructor user.  Click on 
Open to open the project. The Licensing window will automaticlly open 
for you.

21.	 Click on the Network button to open the Network License Settings 
window.

22.	 Click on the New button and under License Server enter the machine 
name or TCP/IP address of the server where your USB hardware lock is 
plugged in.
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23.	 Click on OK to close the Network License Settings window and to 
retrieve the license information. You will return to the Licensing window.

24.	 If your licenses have been successfully retreived you will see all of the 
available aquired modules as well as their status.

25.	 Click OK to close the Licensing window.  The ShipConstructor Navigator 
will load.  Click Close to close the ShipConstructor Navigator.  You have 
now successfully installed ShipConstructor on your network.

Note: If you have other machines on your network that need 
to have ShipConstructor installed you can re-run the client 
installation and activate licensing steps on each machine.
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Standalone Installation
Overview

The basic process of installing ShipConstructor for a Standalone Installation 
involves the following steps:

1.	 Install and/or Configure SQL Server
2.	 Install ShipConstructor Files
3.	 Enable Licensing

Install SQL Server 2005 Express on Windows XP

1.	 Insert the ShipConstructor 2011 DVD into your DVD drive. The Install 
menu will autorun.

 
Note: If you have autorun disabled in Windows or if you have 
downloaded the full install from the internet, you will need to 
load setup manually.
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2.	 Click Install ShipConstructor 2011. The Setup Type menu will appear.
3.	 Click Install Standalone. The ShipConstructor 2011 Standalone 

Installation menu will appear.

4.	 Click Install Microsoft SQL 2005 Express Edition.  The SQL Server 2005 
Express Edition installer will launch, install and configure SQL automatically 
for use with ShipConstructor 2011.

Install SQL Server 2005 Express Edition on 
Windows 7, Windows Vista, Windows Server 2008, 
Windows Server 2008 R2

1.	 Insert the ShipConstructor 2011 DVD into the DVD drive in your 
computer. The Install menu will autorun.

Note: If you have autorun disabled in Windows or if you have 
downloaded the full install from the internet, you will need to 
load setup manually.
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2.	 Click the Exit button to close the Install menu.
3.	 Go to the Start Menu->Computer to open Windows Explorer.

4.	 Right click on the DVD drive that the ShipConstructor 2011 disc is in and 
choose Open from the right click menu.
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5.	 Open the Setup folder to list the contents.

6.	 Copy and paste the SQLExpress folder from the Setup folder onto your 
desktop .

7.	 Open the SQLExpress folder that you just copied to your desktop.
8.	 Edit the template.ini with your favorite text editor.
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9.	 Look for the line that says SAPWD=ShipCon and add a 1 onto the end of 
ShipCon so the line reads as SAPWD=ShipCon1.

10.	 Save the file and close the text editor.
11.	 Launch the SQL setup process by double clicking on the 

SetupSQLExpress icon.  SQL will now launch, install and configure itself 
for use with ShipConstructor 2011.

Installing and Configuring All Other Version of SQL

Note: The following steps are only required if installing SQL Server 2005, 
SQL Server 2005 Express Edition (downloaded version), SQL Server 2008, 
or SQL Server 2008 R2. The version that is included on the ShipConstructor 
2011 disc is pre-configured to work with ShipConstructor 2011.

After installing any of the supported versions of SQL Server as per Microsoft’s 
instructions you will need to go through the following configuration steps to make 
SQL work with ShipConstructor.

These steps will perform the following:

•	 EnableTCP/IP and Named Pipes Protocols
•	 Enable Remote Connections
•	 Turn on the SQL Server Browser Service
•	 Enable xp_cmdshell
•	 Configure the Maximum Degrees of Parallelism
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Configuring SQL Server 2005, or 
SQL Server 2005 Express Edition (downloaded version)

1.	 Go to the Start menu and under the All Programs->Microsoft 
SQL Server 2005->Configuration Tools menu choose SQL Server 
Configuration Manager.

2.	 Under SQL Server Configuration Manager (Local) expand SQL Server 
Network Configuration.

3.	 Select the Protocols for <Instance Name> node in the tree on the left.

4.	 Right-click on TCP/IP and select Enabled.
5.	 Right-click on Named Pipes and select Enabled.
6.	 Choose File->Exit to close the SQL Server Configuration Manager.
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7.	 Go to the Start menu and under the All Programs->Microsoft SQL 
Server 2005->Configuration Tools menu choose SQL Server 2005 
Surface Area Configuration

8.	 Click on the Surface Area Configuration for Services and Connections 
link.
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9.	 Under <Instance Name>\Database Engine\Remote Connections, select 
Local and Remote Connections, and Using both TCP/IP and named 
pipes.

10.	 Click Apply to save the changes.
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11.	 Under <Instance Name>\SQL Server Browser\Service, set the Startup 
type to Automatic, and click the Start button to start the service.

12.	 Click OK to save the changes and return to the SQL Server 2005 Surface 
Area Configuration window. 

13.	 Click on the Surface Area Configuration for Features link.
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14.	 Under <Instance Name>\Database Engine\xp_cmdshell, Check the 
Enable xp_cmdshell checkbox.

15.	 Click OK to close the window and return to the SQL Server 2005 Surface 
Area Configuration window.  Close the SQL Server 2005 Surface Area 
Configuration window to complete the setup.  Your computer is now 
ready for installation of the ShipConstructor Server files.

Note: You may be required to restart your computer after 
making these changes.  Please restart before installing the 
ShipConstructor Standalone files to ensure that the settings are 
up to date.
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Configuring SQL Server 2008, or SQL Server 2008 R2

1.	 Go to your Start menu and choose All Programs->Microsoft SQL Server 
2008->Configuration Tools and click on SQL Server Configuration 
Manager.

2.	 Under SQL Server Configuration Manager (Local) expand SQL Server 
Network Configuration.

3.	 Select the Protocols for <Instance Name> node in the tree on the left.
4.	 Click on the status for Named Pipes and change it to enabled.
5.	 Click on the status for TCP/IP and change it to enabled.
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6.	 Select the SQL Server Services node under SQL Server Configuration 
Manager (Local) from the tree on the left.

7.	 In the right hand side pane, right click on SQL Server Browser and choose 
Properties from the right click menu.

8.	 In the SQL Server Browser Properties window that opened, click on the 
Start button to start the service if it isn’t already started.

9.	 Click OK to save the changes and close the SQL Server Browser 
Properties window.

10.	 Under the File menu choose Exit to close the SQL Server Configutation 
Manager.

11.	 Go to your Start menu and choose All Programs->Microsoft SQL Server 
2008 and click on SQL Server Management Studio.
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12.	 Right click on the Database Server Instance that is being configured. 
13.	 Choose Facets from the right click menu to open the View Facets 

Window.
14.	 Change the Facets dropdown to Server Configuration.
15.	 Change XPCmdShellEnabled to True.

16.	 Click OK to save the changes and close the View Facets window.
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17.	 In the Object Explorer, right click on your server instance and choose 
properties from the right click menu.

18.	 In the Server Properties window that just opened, under Select a page 
click on Advanced.

19.	 In the right hand pane under the Parallelism section, change Max Degree 
of Parallelism to 1.
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20.	 Under Select a page click on Connections.
21.	 Under the Remote server connections section, ensure that Allow remote 

connections to this server is checked.

22.	 Click OK to save the changes and close the Server Properties window.
23.	 Close the Microsoft SQL Server Management Studio window to 

complete the configuration of your SQL server.  Your computer is now 
ready for installation of the ShipConstructor Standalone files. 

Note: You may be required to restart you computer after making these 
changes.  Please restart before installing the ShipConstructor Standalone 
files to ensure that the settings are up to date.
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Configuring Windows Firewall

If a firewall is turned on but not correctly configured, attempts to connect to 
SQL Server might be blocked. If this is the case, consult www.microsoft.com for 
instructions regarding manually configuring Windows Firewall.

Install ShipConstructor Standalone

1.	 Insert the ShipConstructor 2011 DVD into the computer that you wish to 
use for running ShipConstructor. The Install menu will autorun.

Note: If you have autorun disabled in Windows or if you have 
downloaded the full install from the internet, you will need to 
load setup manually.

2.	 Click Install ShipConstructor 2011. The Setup Type menu will appear.
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3.	 Click Install Standalone. The ShipConstructor 2011 Standalone 
Installation menu will appear.

4.	 From the ShipConstructor 2011 Standalone Inatallation menu click 
Install ShipConstructor Standalone. Click Next.
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5.	 The License Agreement appears. Read the agreement carefully, accept the 
terms, and then click Next.
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6.	 You will be presented with the AutoCAD Selection dialog: 
ShipConstructor 2011 can only be installed for one version of AutoCAD. 
This dialog will display all versions of AutoCAD you have installed. Select 
an existing compatible AutoCAD install for use with ShipConstructor 2011 
and click Next.
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7.	 You will be presented with the Custom Setup dialog:
By default, the standalone installation method installs the entire 
ShipConstructor 2011 suite. You can add or remove features if you want to 
further customize your install although it is recommended that most users 
leave the default options. Click Next.
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8.	 During installation, the SCServerSetup will load so that you can configure 
ShipConstructor to connect to your SQL database. On the SCServerSetup 
Screen, under the SQL Server Connection section, choose a Server 
Instance from the dropdown list. If you have installed the bundled SQL 
Server 2005 Express Edition, the SQL Server instance is listed as SHIPCON.

Note: If you do not see the desired instance in the drop-down 
list, ensure that the server is currently running and running on 
the same machine. If it is not, start the service then click  . 
If the server name still does not appear, type it in manually. 
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9.	 Ensure that the Use Integrated Security box is checked if you are running 
SCServerSetup as a machine administrator (typical). Otherwise, enter a 
SQL server username and password for any user that has a sysadmin 
role. 

Note: SQL creates an account called “sa” by default during setup.  
In the bundled SQL Server 2005 Express Edition the password is 
“ShipCon”.  If you installed SQL Server 2005 Express Edition on a 
version of Windows other than XP use the password you entered 
into the template.ini file.  For full versions of SQL you will need 
to use the password you supplied for the “sa” user during setup.

10.	 Verify the details in the SQL Server Configuration Section. Match the 
Data, Log and Backup Paths to those used by your SQL installation.  If you 
install the bundled version of SQL Server 2005 Express Edition on a 32-bit 
system the default paths will be correct.

11.	 If you intend to use ShipConstructor’s Project Split and Merge functionality, 
check the Create ShipConPSM share box.

12.	 Leave the Disable SQL Authentication unchecked. 

Note: If SQL Authentication is disabled, your server is set to 
Windows Authentication Only mode and will be inaccessible via 
SQL Authentication.

13.	 Under the ShipConstructor User section, enter and confirm the user 
password for the ShipConstructor user that will be created in the 
database. Make a note of this password as it will be required to connect to 
any ShipConstructor project you create.
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14.	 Click Setup to have SCServerSetup perform the following tasks.
A.	 Set the Authentication Mode. By default it will verify that the selected 

instance of Microsoft SQL Server supports SQL Authentication. If 
your Microsoft SQL Server is set to Windows Authentication Only, 
it will change the setting to Mixed Mode which supports both 
Windows Authentication and SQL Authentication modes.

B.	 Connect to SQL using the specified account.
C.	 Add the user ShipConstructor with the password ShipCon as a 

sysadmin account.
D.	 Enable the xp_cmdshell stored procedure.
E.	 Set the SQL Server default log, data, and backup folders.
F.	 Create the ShipConPSM shared folder (if checked). The ShipConPSM 

shared folder on the server is writable by everyone. If security is a 
concern you may limit the folder’s security but it must be writable by 
the following users:
i.	 Local System account (or whichever account your SQL Server is 

running as)
ii.	 Any domain user that will perform split and merge operations

15.	 Click Finish to close the window and complete the ShipConstructor 
Standalone installation. You may have to restart your computer before you 
can run ShipConstructor 2011.
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Activate ShipConstructor Licensing

1.	 To ensure locks are viewable by the License Server Software plug the 
Lock(s) into the USB port(s) of your computer.

2.	 Click Start and go to All Programs->ShipConstructor Licensing and click 
on LockView to open the LockView dialog. Ensure that the locks can be 
viewed and click Close. 

Note: If you receive the message, “Unable to View Lock”, contact 
ShipConstructor Software Inc. for technical support.
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3.	 Go to your Start menu and choose All Programs->ShipConstructor 
Licensing and click on License Monitor.

4.	  In the Server textbox enter (Local Computer) and click Connect. The 
locks should appear below in the Locks Attached to the Server area. The 
license information should appear below that in the Licensed Module List.

Note: If the License Monitor is unable to see your lock you may 
need to start the ShipConstructor License Server service.

5.	 Click the Close button once to close the License Server Monitor once you 
have varified that it is connecting to the lock properly.

6.	 You now need to register the locks with ShipConstructor. Go to your Start 
menu and choose All Programs->ShipConstructor 2011 and click on 
ShipConstructor 2011 to launch the program.

7.	 From the ribbon bar choose New Project.



71

Chapter 2 

ShipConstructor Installations

8.	 Choose a folder to store the project.
9.	 For the Project Server choose your computer. This will be listed in the 

format <Machine Name>\SHIPCON.

10.	 Under Template Project(s) put a checkmark in the Use the same 
template for all areas checkbox.
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11.	 Under the .PRO or .XML Template File heading, click on the ... button 
beside Users, Settings & Ranks. Then choose MetricTemplate or 
ImperialTemplate from the dialog box. Click Open.

12.	 After a few seconds you should see that all of the templates have been 
populated with the path and template file that you just chose.
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13.	 Under the Administrator login section, in the User Name field, enter 
ShipConstructor. In the password field, enter the password that you used 
when creating the ShipConstructor user.

14.	 Click OK to create the project.  The project creation will take several 
minutes to complete.

15.	 Once the New Project Created dialog box pops up, press OK to close it.
16.	 You will now need to connect to the project that you just created. Click 

on the Navigator button in the ribbon to bring up the Register Project 
window.

17.	 Click on the newly created project and enter ShipConstructor for the User 
Name. Then enter your password for the ShipConstructor user.  Click on 
Open to open the project. 
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18.	 The Licensing window will automatically open for you.  If your licenses 
have been successfully retreived you will see all of the available aquired 
modules as well as their status.

19.	 Click OK to close the Licensing window.  The ShipConstructor Navigator 
will load.  Click Close to close the ShipConstructor Navigator.  You have 
now successfully installed ShipConstructor on your computer.
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Modify or Remove ShipConstructor
Remove ShipConstructor

To remove an installation of ShipConstructor 2011

1.	 Open the Control Panel.
2.	 Open Add or Remove Programs.
3.	 Find ShipConstructor 2011 in the list of installed applications.

4.	 Click Remove. The confirmation window will appear.
5.	 Click Yes to remove ShipConstructor 2011.

To remove an installation of SSI Licensing

SSI Licensing handles licensing for all ShipConstructor products. You should only 
remove this if you are removing all ShipConstructor products.

1.	 Open the Control Panel.
2.	 Open Add or Remove Programs.
3.	 Find SSI Licensing in the list of installed applications.
4.	 Click Remove. The confirmation window will appear.
5.	 Click Yes to remove SSI Licensing.
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Updating ShipConstructor
It is possible to update existing installations of ShipConstructor whenever a new 
version is released. By doing this you can receive the newest enhancements 
without a lengthy reinstall process. If you are using ShipConstructor in a network 
environment the server and all client workstations should be updated at the same 
time since doing so ensures that the project databases on the server are in sync 
with the software on the client machines. 

Downloading the Update

To download the files necessary to apply the update, visit the ShipConstructor 
website and find the download section. You will need the latest version of the 
update for the product you want to update. 

Applying the Update

1.	 Run the update executable on the machine you want to update. The file 
should be named SC2011Update###.exe where ### refers to the update 
version you have downloaded. The update installation initializes and the 
installer appears.

2.	 Click Update to continue.
3.	 When the update is complete, the installer shows a completed message. 

Click Finish to conclude the update process.
4.	 You may need to reboot your computer at this time. If the Installer 

Information window appears, click Yes to reboot your machine now.

Note: This will complete the updating of the software portion of 
ShipConstructor on this computer. After you have updated all of the 
machines on your network, you will need to update the project databases 
for use with the updated software.
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Update a Project Database Version

Each updated software release may include a new version of the ShipConstructor 
database. Once the update is applied, you can update your ShipConstructor 
projects to the required database version.

Updating a project database converts a project created with a previous 
version of ShipConstructor into the newest version.  Newer project 
databases are not backwards compatible with older versions of 
ShipConstructor.

To update a project database version:

1.	 In Administrator, select the projects you want to update.
2.	 Choose Project > Update to open the Update Project Databases 

window.

3.	 Select the database version you want to update the projects to.
4.	 Click Start. ShipConstructor automatically creates a backup of the 

selected projects in the default backup directory at <SQLDataRoot>\
BACKUP\<database name><current date&time>.bak. Once the update 
has completed, to view a log file of the update, click View Log.

5.	 Click Close.
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Installing the Navisworks Enabler
If you want to view ShipConstructor drawings through Navisworks Review, Manage 
or Simulate, the Navisworks Enabler must be installed. If a Navisworks product is 
installed before installing ShipConstructor 2011, the Navisworks Enabler will be 
installed by default. However, if you install a Navisworks product after installing 
ShipConstructor 2011, you will have to modify the install to include the Navisworks 
Enabler before you can use the associated functionality. To do this:

1.	 Refer to the section Modify ShipConstructor Installation (pg 29).
2.	 At the custom setup dialog, select the feature “Navisworks Enabler” and 

select “This feature will be installed on local hard drive”.
3.	 Click Next, and then click Install.

Technical Support
ShipConstructor Software Inc. offers all customers free technical support for the 
first 90 days after purchase. Additional support is available through Subscription 
(previously known as UM&S).

Office hours:  7:00 am - 5:00 pm Pacific Time 
Toll-free:  1-888-210-7420 
Phone:  1-250-479-3638 
Fax:  1-250-479-0868 
E-mail:    support@ShipConstructor.com 
Web:  www.ShipConstructor.com






