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SHIPCONSTRUCTOR LICENSE AGREEMENT

BEFORE PROCEEDING WITH THE INSTALLATION, YOU MUST ACCEPT THE TERMS OF THIS 
AGREEMENT. INDICATE YOUR ACCEPTANCE OR REJECTION OF THIS AGREEMENT BY CLICKING 
ON THE APPROPRIATE BUTTON. IF YOU CLICK ON “REJECT,” INSTALLATION WILL ABORT.

License Grant.  ShipConstructor Software Inc., #304 – 3960 Quadra Street, Victoria, B.C. Canada, V8X 4A3 (“SSI”) grants 
to the person accepting this Agreement (the “Licensee”) a non-exclusive, non-transferable right to use (the “License”) 
in object code form those program modules, application programming interface (“API”), any other materials provided 
by SSI under this Agreement, and all upgrades, revisions, fixes, updates or enhancements to any of the foregoing 
(“Licensed Materials”) specified in the Licensee’s purchase order or request (“Invoice) solely on the software and 
hardware listed in the Licensed Materials manual (“System Configuration”).  

Academic Institutions/Trial Versions.

A. In the event that the Licensee qualifies as an academic institution user in accordance with SSI’s 
specifications (an “Academic Licensee”), the Academic Licensee and its faculty, employees and students may 
use the Licensed Materials for the singular purpose of either teaching, training users or undertaking research 
provided that the Licensed Materials, and all copies of the Licensed Materials, remain at all times at the 
Academic Licensee’s premises and the Licensed Materials are used for no other purpose than that set forth 
above. The above restrictions are in addition to the restrictions on use set out in Section 5 below.

B. In the event that the Licensee receives a trial version of the Licensed Materials for evaluation purposes, the 
terms and conditions of this Agreement, excluding Sections 15-19, shall continue to apply subject to the 
following provisions:

the License pursuant to Section 1 above shall terminate at the end of the specified trial period;

the Licensee shall return the Hardware Key to SSI immediately upon expiry of the specified trial period and in 
any event within 28 days of the expiry of the specified trial period;

in the event that the Licensee does not return the Hardware Key in accordance with Section 2B.(b) above, SSI 
shall be entitled to invoice the Licensee for and the Licensee shall pay for the costs of the Hardware Key 
plus all shipping and handling expenses and SSI administrative charges; and

in the event that the Licensee elects to and does acquire a License, the terms and conditions of this Agreement, 
excluding Section 2B herein, shall continue on and apply.

Ownership.  All rights, title and interests in and to the Licensed Materials and related documentation shall remain the 
sole property of SSI.  Licensee shall not remove or alter any proprietary rights notices on the Licensed Materials and 
the documentation, and shall reproduce such notices on any copies that it makes.  Licensee shall be liable for the 
security of the Licensed Materials and the documentation in its possession.

Expertise Required.  Licensee is responsible for evaluating whether the Licensed Materials meets Licensee’s 
requirements, and for operating the Licensed Materials and the results obtained.  The Licensed Materials are 
intended for ship modeling and construction purposes only, and must be used by a person who has expertise and 
knowledge in this field.  The Licensed Materials requires independent confirmation of the reliability and accuracy of 
all designs, drawings and other Licensed Materials output. An SSI representative may be made available under a 
separate consulting agreement, as the Licensee’s request to provide training and consultation on the operation or 
integration of licensed materials.

Limitations on Use.  

Licensee shall:

(a) not make more copies of the Licensed Materials than are necessary for the Licensee’s installation of 
the Licensed Materials and shall only create backup copies for archival or emergency restart purposes;

(b) maintain a log of the number of and location of all originals and copies of the Licensed Materials;

(c) include SSI’s copyright, trademark and proprietary notices on any complete or partial copies of the 
Licensed Materials in the same form and location as the notice on any original work;



(d) not attempt to defeat any copy protection;

(e) not modify, any documentation, including any user manuals;

(f) not modify, translate, reverse engineer, decompile or disassemble the Licensed Materials;

(g) not sublicense, transfer, assign, sell, loan, rent or lease the Licensed Materials other than as permitted 
in this Agreement;

(h) use the Licensed Materials for its own internal use only;

(i) not permit any third party to use the Licensed Materials; and

(j) thoroughly test any and all custom interfaces in accordance with general engineering principles.

6. Delivery and Installation.  All Licensed Materials will be delivered in an electronic format by media or method as SSI 
may elect and will be sent to the Licensee’s designated email address or shipping address as specified in the 
Invoice.  Licensee agrees to be responsible for installation of the Licensed Materials.

7. Term of License.  The License term commences on the delivery of the Licensed Materials to the Licensee, and, 
subject to Section 2B above, is either perpetual if so requested on the Order, or on a month to month rental or 
lease basis. If Licensee chooses a lease option the license converts to a perpetual term on Licensee’s payment 
of the balance of the perpetual License fee (prior monthly payments receiving 80% credit).  All Licenses are 
subject to termination in accordance with this Agreement.

8. System Configuration.  Operation of the Licensed Materials requires use of the specified System Configuration, which 
Licensee shall acquire and implement.  SSI shall not be responsible for any operational problems caused by the 
System Configuration.

9. Hardware Keys.  Licensed Materials use requires “Hardware Keys” supplied by SSI, which can be used only at the 
site(s) authorized by SSI.  In the event of a failure of the Licensee’s System Configuration, the Licensee may 
upon advising SSI use the Hardware Keys and Licensed Materials on another system and/or location.

10. License Fees.  Licensee shall pay to SSI the License fees applicable for the Licensed Materials as set out in and in 
accordance with SSI’s Invoice.  

11. Services.  Support services after the Warranty Period (as defined in Section 15 below) are provided by SSI under the 
terms of the SSI Subscription Agreement.  Installation, consulting, training and implementation services, if 
requested by the Licensee, shall be provided by separate agreement and at an additional charge.

12. Taxes.  All amounts payable by Licensee to SSI are exclusive of all commodity taxes, including but not limited to 
applicable sales, use, value added, custom duties, excise taxes and other similar government charges, all of 
which will be paid by Licensee.  If Licensee is required by law to withhold any taxes, then Licensee shall pay SSI 
a gross amount of money such that the net amount received by SSI after deducting or withholding the required 
taxes is equal to the amount of the fee originally charged by SSI.

13. Interest Charges.  If any amount payable under this Agreement is not paid within 30 days of becoming due, SSI shall 
have the right to impose a charge of 2% per month (24% annually) on the unpaid balance of the amount, from 
the due date until the date of receipt of all amounts in arrears including interest.

14. Purchase Orders.  Any purchase order (an “Order”) delivered by Licensee shall at all times be deemed to incorporate 
this Agreement by reference and shall be subject to the applicable provisions of this Agreement.  Any provisions
of an Order shall not apply and shall not be binding upon SSI unless they relate to information which was 
requested by SSI.  In the event of a conflict or an inconsistency between the provisions of an Order and the 
terms and conditions of this Agreement, this Agreement shall govern and supersede to the extent of such 
conflict or inconsistency.

15. Limited Warranty.  SSI warrants that during a period of 90 days from the date of delivery of the Licensed Materials to 
Licensee (the “Warranty Period”), the Licensed Materials will perform substantially in accordance with the 
Licensed Materials documentation specifications, when used in accordance with this Agreement on a properly 
operating System Configuration.  SSI’s sole obligation under this Warranty, and Licensee’s exclusive remedy, 
shall be to use reasonable commercial efforts to correct Errors (a bug, defect or other problem incurred by a 
user in operating the Software that prevents the Software from performing in a manner consistent with the 
applicable specifications set out in the User Manual) that the Licensee identifies to SSI through fixes or 



workarounds free of charge.  If SSI determines that it is unable to make the Licensed Materials perform substantially 
as warranted, Licensee may terminate the License and receive a refund of a portion of the License Fees paid to date.

16. WARRANTY EXCLUSIONS.  THE LIMITED WARRANTY CONTAINED IN SECTION 15 IS IN LIEU OF ALL OTHER 
WARRANTIES, EXPRESS OR IMPLIED.  ALL OTHER CONDITIONS, WARRANTIES, AND REPRESENTATIONS, 
EITHER EXPRESS OR IMPLIED, ARE EXCLUDED, INCLUDING BUT NOT LIMITED TO CONDITIONS, 
REPRESENTATIONS AND WARRANTIES RELATING TO MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE.  SSI DOES NOT WARRANT THAT THE LICENSED MATERIALS ARE COMPLETELY ERROR FREE OR THAT ITS 
OPERATION WILL BE CONTINUOUS AND UNINTERRUPTED. 

17. Maintenance Services.  Licensee may elect, at the expiry of the Warranty Period, to obtain maintenance, support and 
upgrade services from SSI in accordance with and subject to the terms of SSI’s standard Subscription 
Agreement.

18. Loss of Data.  SSI shall not be responsible for any loss of or damage to files or data caused by the Licensed 
Materials, or be required to restore or rebuild files or data.  Licensee shall implementing adequate backup 
procedures to avoid any loss of files and data.

19. Modifications. SSI may, from time to time, provide the Licensee with revisions to the Licensed Materials (the 
“Revised Licensed Materials”). The Licensee shall test any external applications using the revised API before 
implementing the new version. While it is SSI’s intention that the Revised Licensed Materials shall be backward-
compatible with the immediately prior version of the Licensed Materials, SSI does not guarantee or warrant that 
this shall be so, and SSI shall have no liability whatsoever to the Licensee for any failure of the Revised Licensed 
Materials to be backward compatible with any prior version of the Licensed Materials.  Modifications requested 
by the Licensee shall be subject to prior written agreement as to scope and fees payable.  Ownership of all 
Licensed Materials modifications shall vest in SSI.  SSI does not warrant, guarantee or otherwise commit to 
supporting Licensed Materials that has been superseded by Revised Licensed Materials.

20. Confidential Information.  Each party will not use the confidential information of the other party for any purpose 
except for the purpose described in this Agreement, and shall not disclose it to any other person except on a 
confidential basis to its employees and representatives who have a need-to-know the confidential information for 
such purposes.  This Section 23 shall not apply to confidential information which (a) is or has become readily 
available to the public in the same form other than by an act or omission of the receiving party, (b) was lawfully 
obtained in the same form by the receiving party from a third party not under an obligation of confidence to the 
disclosing party, (c) was in the receiving party’s possession in the same and material form prior to its receipt 
from the disclosing party and did not otherwise originate from the disclosing party, or (d) is required to be 
disclosed by operation of law.

21. Termination.  This Agreement may be terminated by either party, immediately by written notice, if the other party 
commits a breach of any material provision of this Agreement, including a failure to make payment when due, 
and fails to correct or rectify such breach within 30 days of receipt of the notice requesting it to do so.  SSI shall 
be entitled to place time-lock devices and other disabling features in the Licensed Materials that become 
effective in the event that the Licensee has failed to comply with its payment obligations hereunder and as set 
out in SSI Invoices.

22. Effect of Termination.  Upon termination of this Agreement Licensee shall immediately cease using the Licensed 
Materials, and within 14 days of termination return all Hardware Keys to SSI.

23. CONSEQUENTIAL DAMAGES.  IN NO EVENT SHALL SSI BE LIABLE FOR ANY LOSS OF DATA OR PROFITS, ECONOMIC 
LOSS OR SPECIAL, INDIRECT, INCIDENTAL, CONSEQUENTIAL OR PUNITIVE DAMAGES WITH RESPECT TO THIS 
AGREEMENT OR THE LICENSED MATERIALS, HOWEVER CAUSED, EVEN IF SSI HAD OR SHOULD HAVE HAD ANY 
KNOWLEDGE OF THE POSSIBILITY OF SUCH DAMAGES.

24. DAMAGES LIMITATION.  THE MAXIMUM LIABILITY OF SSI FOR ALL CLAIMS AND DAMAGES OF ANY KIND, WHETHER 
FOR FUNDAMENTAL BREACH OR ANY OTHER CAUSE UNDER THIS AGREEMENT, SHALL BE LIMITED IN THE 
AGGREGATE TO THE TOTAL OF ALL FEES PAID BY LICENSEE.

25. LIMITATION OF NON-APPLICABILITY.  IN SOME JURISDICTIONS THE EXCLUSION OR LIMITATION OF WARRANTIES OR 
LIABILITY MAY NOT BE APPLICABLE, AND IN SUCH JURISDICTIONS SSI HEREBY LIMITS ITS LIABILITY TO THE 
FULLEST EXTENT PERMITTED BY LAW.



26. Applicable Law.  This Agreement shall be subject to and construed in accordance with the laws of the Province of 
British Columbia, Canada, excluding its conflict of laws rules and the application of the UN Convention on 
Contracts for the International Sale of Goods.

27. References.  SSI shall be allowed to incorporate Licensee’s name in SSI’s customer reference list and to use it for 
marketing.

28. Dispute.  If any dispute arises under this Agreement, a good faith attempt to resolve the dispute will be made by 
senior management of both parties at a mutually agreeable site and time.  If the parties are unable to reach 
agreement within 30 days after a request for such meeting, the dispute shall be referred to arbitration in 
English, before one arbitrator in Victoria, British Columbia, Canada, in accordance with the Commercial 
Arbitration Act of the British Columbia. 

29. Entire Agreement.  This Agreement contains the entire agreement between the parties and shall supersede all prior 
discussions and agreements between the parties regarding its subject matter.

30. Amendment.  Any amendment of this Agreement must be in writing and signed by duly authorized representatives of 
the parties.

31. Waiver.  The waiver by any party of a breach by the other party of this Agreement shall not be construed as a waiver 
by such party of any succeeding breach by the other party of the same or another provision.

32. Assignments.  Licensee may not assign or transfer the License or Licensee’s rights or obligations under this 
Agreement without SSI’s prior written consent, and any such assignment or transfer without consent shall be 
null and void. A transfer of all or substantially all of the voting stock of the Licensee shall constitute a transfer 
for these purposes and shall be subject to SSI’s prior written consent.

33. Successors and Assigns.  This Agreement will bind and enure to the benefit of the parties and their respective 
successors and permitted assigns.

34. Severability.  In the event that any provision of this Agreement is declared invalid, illegal or unenforceable by a court 
having jurisdiction, then the remaining provisions shall continue in full force and effect.

35. Force Majeure.  Except as related to Licensee’s obligation to make payments to SSI, neither party shall be liable for 
delays or non-performance if such delays or non-performance are beyond such party's reasonable control.  A 
delayed party shall promptly notify the other party in writing stating the cause of the delay and its expected 
duration and shall use commercially reasonable efforts to remedy a delay or non-performance as soon as 
reasonably possible.

36. Survival.  The provisions of Sections 0, 5, 10, 12, 13, 16 and 18-28 shall survive the expiry or termination of this 
Agreement.

37. Language.  It is the express will of the parties that this Agreement and related documents have been prepared in 
English.  C’est la volonté expresse des parties que la présente Convention ainsi que les documents qui s’y 
rattachent soient rédiges en anglais.

#363338
28/05/2010
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Project Management
The Project Management manual helps project managers organize and administer projects and the team working on 
projects.

Administrator
Administrator is a stand-alone utility that lets you set up and manage projects. See Appendix: Menus, Tools & Commands
(page 30) for more details on working with Administrator.

Start Administrator

To start Administrator

Choose Start > All Programs > ShipConstructor2011 > Utilities > Administrator2011.

The Select Database Server window appears.

1. Select the Server Name from the list (or enter a name at the bottom of the window).

2. Enter the system administration Login Name and Password.

A default system administration account exists:

• Login Name: ShipConstructor

• Password: ShipCon

3. Click OK to close the Select Database Server window.

The Administrator window appears, listing all projects on the server.
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Refresh the Project List in Administrator

To refresh the project list in Administrator

1. In Administrator, choose Server > Refresh Project List (page 32).

Disconnect Administrator from the Current Server

To disconnect Administrator from the current server

1. In Administrator, choose Server > Disconnect (page 32).

Connect Administrator to a Server

To connect Administrator to a server

1. In Administrator, choose Server > Connect (page 32) to open the Select Database Server window.

See Start Administrator (page 1) for details.

Manager
Manager is a utility that lets you set up project settings, project libraries, and user permissions.

To start manager

1. In ShipConstructor, choose ShipConstructor > Manager.

2. The Manager window appears.

See Manager (page Error! Bookmark not defined.) in Appendix: Menus, Tools & Commands (page 30) for further 
details.
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Project Set Up & Maintenance
Before you begin work on a vessel, you must set up a ShipConstructor project for it. A project is the container for the 
vessel’s 3D model, libraries, and drawings.

A project consists of three things:

• A project file (*.PRO)

• Several folders containing drawings

• A database containing all the project’s data

Note: The terms project and database are sometimes used synonymously.

Create a Project
To create a project

Note: You must have administrative privileges in ShipConstructor to create a project.

1. Choose ShipConstructor > Project > New Project (page 30) to open the New ShipConstructor Project window.

2. Enter the Project Folder name or click the button and select the folder.

Note: Do not use an existing folder that already contains a ShipConstructor project. Each ShipConstructor project 
must be in its own folder.

3. Select the Project Server.

4. To use a single template for the entire project, turn on Use the same template for all areas, click the button for 
Users & Settings, and select a template.

To use a different template for each discipline, turn off Use the same template for all areas, click the button for 
each discipline, and select a template.

You can select one of two project templates included with ShipConstructor:

• C:\Program Files\ShipConstructor2011\Project Templates\MetricTemplate.xml

• C:\Program Files\ShipConstructor2011\Project Templates\ImperialTemplate.xml

Or you can select any ShipConstructor project and use it as a template. (ShipConstructor will remove any project-
specific items and retain things like templates, stocks, and general settings.)

5. Enter the User Name and Password for a user with administrative privileges in ShipConstructor.
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The default administrative account is:

• User Name: ShipConstructor

• Password: ShipCon

6. Click OK to create the project.

It may take a few minutes for ShipConstructor to create the project.

Note: If the project template is from an older version of ShipConstructor, you may see a message similar to the 
following.

You must update the project template to the latest version of the database. See Update a Project Database 
Version (page 11).

You can now register to the project. You can connect to the project using the administrative account you specified in 
Step 5.

Open a Project
To open a project

1. Choose ShipConstructor > Navigator to open Navigator.

• If you do not currently have a project open (for example, after initially starting ShipConstructor), the Select 
ShipConstructor Project window appears.

• If you currently have a project open, Navigator appears. Select the project from the component list (for example, 
SC2011Demo), and click Change Project to open the Register Project window.
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2. Select the project from the list or click Browse to locate a project file. (A ShipConstructor project file has a *.pro
extension.)

3. Enter your User name and Password.

Note: For the project templates, the User name is ShipConstructor and the Password is ShipCon.

If you do not have a user account, ask your system administrator to set one up, or see User Accounts (page 19) for 
details.

4. Click Open.

Note: The Licensing window will now appear. See Get Licenses in the Structure manual for details. 

Copy a Project
You can copy a project or database from within ShipConstructor or Administrator.  There is a subtle difference between 
the 2 options however: if you use the "Copy Project" command in ShipConstructor, it will create a copy of your project 
(including drawings, etc) and generate a new project GUID (identifier) for the database.  If you use administrator to copy 
your project database, it will just do a "copy", not changing the GUID.

The purpose of the project GUID is that it is stored in the project drawing files, and you will receive a warning if you open a 
drawing file from ProjectA, while connected to the ProjectB database, to prevent accidental confusion between the 
projects.

The administrator “Copy” command is useful for:

- Storing a past revision of your project

- Renaming your project database



Project Set Up & Maintenance

6

- Do not use this option if you intend to continue work in both copies of the project.  The reason for this is for 
your own safety.  If you open a drawing file from one copy of the project while connected to the database of 
the other copy, it will try to bring your database up to date with the contents of the file, and this is undesired 
behavior.

The ShipConstructor “Copy Project” command is useful for:

- Creating a new project based on an existing project

To copy a project (in ShipConstructor)

1. Choose ShipConstructor > Project > Copy Project (page 30) to open the Copy Project window.

2. Select the Project File you want to copy by clicking Browse under Source Project.

3. Enter the Project Name for the new project.

4. Select a Folder for the new project by clicking Browse.

ShipConstructor will create a new project folder (with the same name as the Project Name) within the Folder you 
specify.

5. Enter the Username and Password for a user with administrative privileges in ShipConstructor.

6. Click OK.

7. ShipConstructor copies the project database and all drawing files and then automatically logs you into the new 
project.

Note: If the source project is from an older version of ShipConstructor, you may see a message similar to the 
following.
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You must update the project template to the latest version of the database. See Update a Project Database 
Version (page 11).

To copy a database (in Administrator)

1. In Administrator (page 1), choose Database > Copy (page 32).

The Copy Database window appears.

2. Enter the name for the new project.

3. Click OK to copy the project.

Delete a Project
To delete a project

1. In Administrator (page 1), select the project you want to delete.

2. Choose Database > Delete (page 32).

Monitor Project Activity
Many project database administration functions require exclusive access to a project database. You can monitor project 
activity to check for active connections to the project database.

To monitor project activity

1. In Administrator (page 1), select the project you want to monitor.
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2. Choose Database > Show Connected Processes (page 34) to open the Connected Processes window.

The window lists all processes currently connected to the project database.

If the window is empty, there are no processes currently connected to the project database.

Click Refresh to refresh the display in the Connected Processes window.

3. Click Close to close the Connected Processes window.

Back Up a Project
It is important to create backups of your project periodically. You can manually create a backup at any time, or set up 
scheduled (automatic) backups.

Manually Back Up a Project
You can manually back up one or multiple projects at one time.

To manually back up a project

1. In Administrator (page 1), select the projects you want to back up.

2. Choose Database > Backup (page 33) to open the Select Backup Location window.

3. Select the location to save the backup file and, if desired, modify the File Name of the backup file.

Note: If you select an existing file from the folder tree or enter a File Name of an existing file, the existing file will 
be replaced with the new project backup file.

4. Click OK.

Note: If you selected multiple projects in Step 1, the Select Backup Location window will only ask you for a folder. 
The filenames will be generated automatically.

Set Up Scheduled (Automatic) Project Backups
You can schedule automatic backups for one or multiple projects at one time.

Note: The scheduled backups feature is unavailable on SQLExpress servers.  If you are using SQL Express, you will 
want to use a 3rd party application to backup your project databases on a regular basis.  Alternately, you can use 
the windows scheduler to schedule backups. For more information, see the knowledge base article here 
(http://www.shipconstructor.com/kb/questions.php?questionid=1637).

To set up a scheduled (automatic) project backup

1. In Administrator (page 1), select the projects to schedule automatic backups for.

2. Choose Database > Schedule Backup (page 34) to open the Backup Schedule window.

http://www.shipconstructor.com/kb/questions.php?questionid=1637
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3. Select when and how often the scheduled backup will occur:

• Once on a specific date and time.

• Weekly on a specific day and time.

• Daily at a specific time.

And specify the date, day, and time.

4. Enter the Backup Folder, or click and select a folder on the server machine to place the backup file in.

5. Click Add to create the scheduled backup job.

Note: If your SQL Server Agent is not currently running, the following message appears.

6. Click Yes to start the SQL Server Agent. The SQL Server Agent must be running in order for the scheduled backup job 
to occur.

The scheduled backup job appears in the Current scheduled backup jobs list.

7. Click OK to close the Backup Schedule window.

Note: After a Once on scheduled backup has occurred, it will no longer appear in the Current scheduled backup jobs list.

Remove a Scheduled Backup Job

To remove a scheduled backup job

1. In Administrator (page 1), select the projects to remove a scheduled backup job from.

2. Choose Database > Schedule Backup (page 34) to open the Backup Schedule window.

3. Select the scheduled backup job from the Current scheduled backup jobs list.

4. Click Remove.
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Restore a Project Backup
To revert a project database to the state it was at the time of a previously created backup, use the “Restore” 
command.  

To restore a project backup

1. In Administrator (page 1), select the project you want to restore.

2. Choose Database > Restore (page 33).

The Select backup file window appears.

3. Select the backup file you want to restore.

4. Click OK.

ShipConstructor automatically creates a backup of the original project in the default backup directory (usually 
C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\BACKUP\).

Add Database from Backup
To add a new project database to the server from a backup file, use the “Add Database from Backup” command.

To add a new database from a backup file

1. In Administrator (page 1),  choose Tools > Add Database from Backup.
2. You will be prompted for the name of the database you will be creating. Enter the database name, and Click 

OK.

3. The Select backup file window appears.
4. Select the backup file you want to add.
5. Click OK.

Transfer a Project to Another Server
You can move a project to another server within your organization or transfer a copy of a project to another server outside 
your organization (for example, to outsource a portion of the work).

To move a project to another server

1. Back up the project on its original server (see Manually Back Up a Project (page 8)).

2. Copy the backup file to the project directory.

3. If you are transferring the project to a remote location, package the entire project directory into a single archive file 
using a compression utility like WinZip. Then transfer the package to the new server and unpack it.  If you are 
transferring the project to another server at the same location, you do not need to package it. You can simply copy 
the entire project directory to the new server.

4. On the new server, run the Administrator command Tools > Add Database from Backup (page 35).  Select the 
backup file you created in Step 1.

5. On the new server, open the *.PRO file using a text editor like Notepad and do the following:

• Change Server=<OldServerName> to Server=<NewServerName>.
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• Make sure Database=<DBName> points to the correct project database.

6. Save the *.PRO file.

Update a Project Database Version
ShipConstructor Software Inc. periodically releases updates of ShipConstructor containing new features and 
improvements. Each update includes a new version of the ShipConstructor database. In order to make use of an update, 
you must download and install a file for updating the ShipConstructor software (see Updating ShipConstructor in the 
Installation Guide). Once the update is applied, you can update your ShipConstructor projects to the required version.

To update a project database version

1. In Administrator (page 1), select the projects you want to update.

2. Choose Database > Update (page 33) to open the Update Project Databases window.

3. Select the database version you want to update the projects to.

4. Click Start.

ShipConstructor automatically creates a backup of the selected projects in the default backup directory at 
<SQLDataRoot>\BACKUP\<database name><current date&time>.bak<ServerVersion>.

Note: If any errors occur during the update of your project, the project automatically reverts to its original state.

Once the update is complete, you can view a log file of the update by clicking View Log.

5. Click Close

Execute SQL
This feature facilitates running SQL scripts against project databases.  This can be helpful when diagnosing issues or 
running custom queries.

To re-attach a project database to its server

1. Select the project database you want to run the script on.  You may the shift or control keys to select multiple 
databases.

2. In Administrator (page 1), choose Database > Execute SQL (page 33).

Use the file selector dialog to choose a SQL script to run.

3. Click Open.

4. If the SQL script returns a result then a new dialog with appear and the results will be displayed as table.  The results 
can be saved using the save button or they can be copied to the clip board and pasted into a spreadsheet 
application.  Hitting done will close the dialog.  If more than one database was selected, then another dialog will 
open (one for each database).

5. Upon completion, a dialog will appear.  A log of the steps may be viewed, or the dialog may be closed by clicking on 
OK.

Check Project
The Check Project command examines your project for data inconsistencies.  If any inconsistencies are found, it will 
describe the nature of each one, and recommend a course of action to resolve the problem.  Most problems can be 
resolved using the Repair Project command. See Database > Repair Project (page 33).
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Repair Project
The Repair Project command will fix many of the data inconsistencies in your project found by the Check Project 
command.  It is highly recommended you run Check Project prior to running Repair Project, and record the output of the 
Check Project command for review. See Database > Check Project (page 33).

Database Maintenance
Periodically while working on a project, you may want to perform maintenance on the project to reduce the amount of 
space it occupies on the server’s hard drive.

Running this command will also rebuild your table indexes, which you can think of as similar to doing a "defrag" on your 
hard drive, and can result in a minor performance benefit if performed on an occasional basis.  Typically, running this 
command once a week is adequate for any project.

Manual Maintenance
To run the project maintenance job on your project immediately

1. In Administrator (page 1), select the projects you want to compact.
2. Choose Database > Run Maintenance (page 34).

It may take several minutes for ShipConstructor to process each project.
The results of the process appear in the bottom portion of the Administrator window.

Set Up Scheduled (Automatic) Project Maintenance
You can schedule automatic maintenance for one or multiple projects at one time.

Note: The scheduled maintenance feature is unavailable on SQLExpress servers.  If you are using SQL Express, you 
will need to perform compacts manually, or can use the windows scheduler to schedule maintenance.  For more 
information, see the knowledge base article here 
(http://www.shipconstructor.com/kb/questions.php?questionid=1925).

To set up a scheduled (automatic) project maintenance

1. In Administrator (page 1), select the projects to schedule automatic backups for.

http://www.shipconstructor.com/kb/questions.php?questionid=1925
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2. Choose Database > Schedule Maintenance (page 34) to open the Maintenance Schedule window.

3. Select when and how often the scheduled maintenance will occur:

4. Once on a specific date and time.

5. Weekly on a specific day and time.

6. Daily at a specific time.

7. Specify the date, day, and time.

8. Click Add to create the scheduled maintenance job.

9. If your SQL Server Agent is not currently running, the following message appears.

Click Yes to start the SQL Server Agent. The SQL Server Agent must be running in order for the scheduled backup 
job to occur.

10. The scheduled maintenance job appears in the Current scheduled maintenance jobs list.

11. Click OK to close the Maintenance Schedule window.

Note: After a Once on scheduled maintenance has occurred, it will no longer appear in the Current scheduled 
maintenance jobs list.

Remove a Scheduled Maintenance Job

To remove a scheduled maintenance job

1. In Administrator (page 1), select the projects to remove a scheduled backup job from.
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2. Choose Database > Schedule Maintenance (page 34) to open the Maintenance Schedule window.
3. Select the scheduled backup job from the Current scheduled maintenance jobs list.
4. Click Remove.

Re-attach a Project Database to Server
A project database must be associated with or attached to a specific server. In certain rare cases, a project may become 
detached from its server (for example, if you re-install the server). If a project becomes detached from its server, you must 
re-attach it.

To re-attach a project database to its server
1. In Administrator (page 1), choose Tools > Re-Attach Database (page 35).
2. The Re-attach Databases window appears, listing detached databases for the current server.
3. Select the project database you want to re-attach.
4. Click Attach.
5. Click Close to close the Re-attach Databases window.

Synchronize Server Logins
When using SQL Authentication (the default setup for ShipConstructor. See Windows Authentication (page 15)), each 
user account is given a login on the database server.  Normally logins are handled automatically when adding and 
removing users, but in the event that they are not, this command can be used to make sure that all of the required server 
logins exist for every user in the project database.

To make sure user logins exist on the server for all users in the project,
1. In Administrator (page 1),  select the project database for which you want to synchronize users.
2. Select Database > Synchronize Server Logins (page 34).
3. Done. Any new logins created will have a password of ShipCon.  To change user passwords, Change User 

Passwords (page 21).

Unlock Database
When a project database is being updated to a new version, or during Project Split & Merge Refresh or Merge operations, 
the database is placed in a “locked” state, preventing users from connecting to the project while the operation is being 
performed.  Normally, the project should automatically unlock itself when the operation completes, but in the event it 
does not, this command allows you to unlock the project so that users can connect to the project.  Before running this 
command, make absolutely sure that the database is not in the middle of an update, refresh, or merge operation.

To unlock your project,
4. In Administrator (page 1),  select the project database you wish to unlock.
5. Select Database > Unlock (page 34).
6. Done. You will now be able to connect to this project.

View Project Database Raw Data
In certain rare cases, you may need to view the raw data contained in the project database (for example, to analyze 
specific problems or repair errors). By editing the project database raw data, you can easily destroy valuable data. We 
recommend that only knowledgeable users attempt to edit the database.

To view project database raw data

1. In Manager (page 2), choose Database Utilities > Raw Data (page 41) to open the Database Raw Data window.

2. Under Server Objects, select a Table or View to display its values.
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3. Click OK to close the Database Raw Data window.

To execute a stored procedure

1. In Manager (page 2), choose Database Utilities > Raw Data (page 41) to open the Database Raw Data window.

2. Under Server Objects, select the Procedure you wish to run.

3. Edit the input parameter values (if any).

4. To execute the procedure with the input parameters you have specified, click Execute.

5. Any output parameters will be displayed in the top-right window.  If the stored procedure returns a result set, it will 
be shown in the main (lower) window.

6. Click OK to close the Database Raw Data window.

Windows Authentication
Windows Authentication is a login scheme similar to SQL server authentication, but with several features that establish it 
as a useful alternative. The main improvements are enhanced security, a consolidated security policy and the 
convenience of only having to login to Windows to gain SQL server access.  The benefit of these features is in the 
flexibility to enforce password complexity and expiration uniformly over a large number of users and domain groups, and, 
for the security conscious, never having to send a password over the network connecting the client and server.

Under the Windows Authentication scheme domain users and groups are given SQL server access rights based on their 
Windows login information, and it is these Windows credentials that are examined when the SQL server receives a 
request. Since most internal networks already have some type of domain configuration, managing access restrictions can 
be much simpler. For more information on Windows domain users and groups please see the Windows help 
documentation. 

The use of Windows Authentication does not remove the necessity of ShipConstructor users, simply because a Windows 
user must still be constrained by the ShipConstructor permissions system. So an individual user must still be created for 
each person who wants access to a ShipConstructor project; however, no passwords need to be entered and all access 
restriction will be based on a user’s Windows credentials.

Setup Windows Authentication

Start SQL Server Management Studio
1. If you are using MS SQL Server Express (this is what installs off of the ShipConstructor  CD) then you will need to 

download Microsoft SQL Server Management Studio Express. 

• Go to the following webpage: http://www.microsoft.com/downloads/details.aspx?familyid=08E52AC2-1D62-
45F6-9A4A-4B76A8564A2B&displaylang=en

• Download & install the version most appropriate for your system.

2. Choose Start > All Programs > Microsoft SQL Server 2008 > SQL Server Management Studio Express.

3. Select the SQL Server that hosts your ShipConstructor project(s) and enter your login details.

• If you’re a member of the Administrators group on the SQL server machine then you can connect via Windows 
authentication, otherwise use your usual SQL administrator login.

4. Click Connect.

SQL Server Management Studio will display the SQL Server, as well as some subcategories relevant in the following 
sections.

http://www.microsoft.com/downloads/details.aspx?familyid=08E52AC2-1D62-45F6-9A4A-4B76A8564A2B&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=08E52AC2-1D62-45F6-9A4A-4B76A8564A2B&displaylang=en
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Add server access for a user

1. Expand the server node (as shown above), right-click Security, and choose New > Login…

2. Click the Search… button that’s beside the Login name text box.

3. Click Object Types… and check the Users box, click OK.

4. Click Locations… and select the machine or domain that the Windows user you’re adding belongs to, click OK.

5. Type the Windows user-name into the textbox, click Check Names, the name should resolve to something along the 
lines of “Full User Name (user@domain)”, click OK.

6. Select Windows authentication, beneath Login name.

7. (Optional) To grant the user administrator privileges, select the Server Roles page on the left-hand side, and check 
the sysadmin box.

• Administrator privileges are necessary if the user will be required to create ShipConstructor projects, use Project 
Split & Merge, or manage projects with Administrator.

8. Click OK.

Add server access for a group

1. Expand the server node (as shown in the Start SQL Server Management Studio section), right-click Security, and 
choose New > Login…

2. Click the Search… button that’s beside the Login name text box.

3. Click Object Types… and check the Groups box, click OK.

4. Click Locations… and select the machine or domain that the Windows group you’re adding belongs to, click OK.

5. Type the Windows group-name into the textbox, click Check Names, the name should resolve to something along the 
lines of “Group Name”, click OK.
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6. Select Windows authentication, beneath Login name.

7. (Optional) To grant the group administrator privileges, select the Server Roles page on the left-hand side, and check 
the sysadmin box.

• Administrator privileges are necessary if the group members will be required to create ShipConstructor projects, 
use Project Split & Merge, or manage projects with Administrator.

8. Click OK.

Add database access for a user or group

9. Expand the database node for the database to which you wish to grant access, expand Security, then right-click 
Users and choose New > User…

10. Click the Search… button that’s beside the Login name text box.

11. Enter the name of the server login you created previously, or click the Browse… button to list all of the server’s 
logins.  Click OK.

12. Set the User name field to match the Login name field.

13. Set the Default schema field to: dbo

14. Check the db_owner role membership checkbox.
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15. Click OK.

Adding a Windows Authentication ShipConstructor User
Adding a new ShipConstructor user follows the same process regardless of which authentication type is used, with only 
one complication, the ShipConstructor user must have the same name as the Windows user associated with it.

• The ShipConstructor user name should be identical to what the corresponding Windows user enters when they 
login. However the domain should not be included, so the Windows user MyDomain\Me would created a 
ShipConstructor user named Me.

• See User Accounts (page 19) for details on User Creation. 

Disabling SQL Logins
To reap the security benefits of Windows authentication SQL logins must be disabled. 

Method 1: Set server authentication to Windows Authentication using ServerSetup
1. Run the ServerSetup application.

2. Choose, or enter the appropriate Server in the Server Instance drop-list.

3. Check the Disable SQL Authentication checkbox.

4. Verify that other settings are correct.

5. Click Setup.

Method 2: Set server authentication to Windows Authentication using Management Studio
6. Connect to the SQL server hosting your ShipConstructor projects with SQL Server Management Studio, as shown in 

the Start SQL Server Management Studio (page 15) Section.

7. Right-click the server node and choose Properties.

8. Select the Security page on the left-hand side, and choose the Windows Authentication mode option under Server 
authentication.

9. Click OK.

Logging in with Windows Authentication
Using Windows Authentication is a fast and convenient alternative to manually entering a user-name and password. Any 
dialog that previously required login information now has a checkbox labeled Use Windows Authentication. When this box 
is checked your Windows user-name will be listed as the Login name and your Windows credentials will be used to 
establish a server connection, in lieu of a typed in login.

Connecting to a ShipConstructor project

1. Start ShipConstructor and choose ShipConstructor > Navigator to open Navigator.

• The Select ShipConstructor Project window should appear.



User Accounts

19

2. Select the project from the list or click Browse to locate a project file. (A ShipConstructor project file has a *.pro
extension.)

3. Check the Use Windows Authentication box

• Your Windows user-name should appear in the User Name textbox.

4. Click Open.

User Accounts
Before beginning work on a project, you must set up a user account for each user. Whenever a user opens a project, they 
must log on to their user account. User accounts let ShipConstructor track project changes by user. User accounts also let 
you control user access to projects and ShipConstructor features.

Create a User Account

To create a user account

1. In Administrator (page 1), choose Tools > Manage Users (page 35) to open the Manager Users window.
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2. Click Create User to open the New ShipConstructor User window.

3. Enter a User name and Password (and confirm the password) for the new user.

4. Select the projects that you want the new user to have access to.

5. Click OK.

6. Note: For a Windows Authentication user, the User name must match the Domain User name. For example, the 
Windows user MyDomain\Me would create a ShipConstructor user named Me.

Copy a User Account
If you are creating a new user account that will have similar privileges to an existing account, you can save time by 
copying a user account.

To copy a user account

1. In Administrator (page 1), choose Tools > Manage Users (page 35) to open the Manage Users window.

2. Select an existing user account that has privileges similar to the privileges you want for the new user.

3. Click Copy User to open the Copy ShipConstructor User window.

4. Enter a User name and Password and confirm the password for the new user.

5. Click OK.

Delete a User Account

To delete a user account

1. In Administrator (page 1), choose Tools > Manage Users (page 35) to open the Manage Users window.

2. Select the user account.

3. Click Delete User.

The Confirm Delete User window appears.

4. Click Yes.

Add a User to a Project

To add a user to a project

1. In Administrator (page 1), choose Tools > Manage Users (page 35) to open the Manage Users window.

2. Select “User” or “Admin” for the project to add the user to.
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Note: If you select “User”, the user will not have any permissions in the project. You must set up the user’s 
permissions. See Edit User Permissions (page 22).

Remove a User from a Project

To remove a user from a project

1. In Administrator (page 1), choose Tools > Manage Users (page 35) to open the Manage Users window.

2. Select “No Access” for the project you want to remove the user from.

Note: If you remove a user from all projects, ShipConstructor will delete the user account (see Delete a User 
Account (page 20)). If you plan to add the user to another project, do so before removing the user from all other 
projects.

Change User Passwords

To change a user password

1. In Administrator (page 1), choose Tools > Manage Users (page 35) to open the Manage Users window.

2. Select the user account that you want.

3. Click Change Password to open the Enter Password window.

4. Enter a new Password and Confirm the password.

5. Click OK.

Note: The steps above only apply to SQL logins. NT Domain passwords will not be changed.

Change the System Password
The ShipConstructor user is the system administration user account. The default password for this account is ShipCon.  
This password is case-sensitive on most server configurations.

To change the system password
1. In Administrator (page 1), choose Tools > Manage Users (page 35) to open the Enter Password window.

2. Enter a new Password and confirm the new password.

3. Click OK.

Grant Administrator Access to a User
In order for a user to create a new project, or use the Project Split & Merge functions, they must have administrator 
access.  This means the user will be added to the sysadmin role on your sql server.

To grant administrator access to a user

1. In Administrator (page 1), choose Tools > Manage Users (page 35) to open the Manage Users window.

2. Check the check box under DB Admin for the user.

Account Access
When a user is granted access to a ShipConstructor database, they are added to the db_owner role for that particular 
database.  If a user is granted administrator access by clicking the “DB Admin” checkbox in administrator for that user, 
then they are also assigned to the sysadmin role on the server.  Typically only the user named “ShipConstructor” should
be assigned sysadmin access.
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User Permissions
User permissions are a way to prevent specific users from using specific functions. For example, you may want to restrict 
all structural designers so they can only use structural functions (and not, for example, pipe functions). Or you may want 
to restrict a junior designer or a user who is new to ShipConstructor from using features that require greater skill or 
responsibility. This helps prevent mistakes and gives new users confidence knowing that they cannot inadvertently
destroy valuable data.

You set up user permissions by project. In other words, a user could have limited permissions on one project, but greater 
permissions on another project. When you set up user permissions, you do so for the current project.

You can set up user permissions either for individual users or for groups of users.

Permission groups are a way of setting up user permissions for groups of users. You first create permission groups and
assign users to those groups and then set up the permissions of each group. Each user then inherits the permissions of 
the groups they belong to.

When setting permissions for a user group, you explicitly allow or deny each permission for the group. Allow gives 
permission to all users in the group and deny denies permission for all users in the group.

If there is a conflict between the permission of a user and the permission of a group that the user belongs to, the user 
permission takes precedence. If a user belongs to more than one group and there is a conflict between the permissions 
of each group, the user is denied permission.

Edit User Permissions
To edit user permissions

1. In Manager (page 2), choose General > User Permissions (page 38) to open the User Permissions window.

2. In the Users list, select the user you want to edit.

3. In the Permission Groups list, check the check boxes of the groups that you want the user to belong to.

4. Under User Overrides, set the Access for each feature to one of the three options:

• Allowed – The user has permission to use the feature, even if they belong to a permission group that does not 
allow access to the feature.

• Denied – The user does not have permission to use the feature, even if they belong to a permission group that 
does allow access to the feature.

• From Group – The user’s permission to use or not use the feature is based on the permission groups that the 
user belongs to. (If the user belongs to more than one group and there is a conflict between the permissions of 
each group, then the user is denied permission.)

5. Click OK to close the User Permissions window.

Create a Permission Group
To create a permission group

1. In Manager (page 2), choose General > User Permissions (page 38) to open the User Permissions window.

2. Under Permissions Groups, click New.

3. Enter a name for the permission group and press Enter.
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Add and Remove Users to and from Permission Groups
To add and remove users to and from permission groups

1. In Manager (page 2), choose General > User Permissions (page 38) to open the User Permissions window.

2. In the Users list, select the user you want to add or remove from permission groups.

3. In the Permission Groups list you need to do two things:

• Check the check boxes of the groups that you want the user to belong to.

• Uncheck the check boxes of the groups that you do not want the user to belong to.

Note: If you add a user to two permission groups and there is a conflict between permissions in those groups, 
then the user is denied permission.

Edit Group Permissions
To edit group permissions

1. In Manager (page 2), choose General > User Permissions (page 38) to open the User Permissions window.

2. Under Permission Groups, select the group you want to edit.

3. Click Edit to open the Edit Permission Group window.

4. Set the permission for each feature:

• Allow – Users in the group have permission to use the feature.

• Deny – Users in the group do not have permission to use the feature.

Note: You can override group permissions for specific users by setting their user permissions (see Edit User 
Permissions (page 22)).

5. Click OK to close the Edit Permission Group window.

Export Permission Groups
You can export permission groups to an XML file (for example, to import into another project or to edit using other 
software).

To export permission groups

1. In Manager (page 2), choose General > User Permissions (page 38) to open the User Permissions window.

2. Click Export XML to open a File Browser.

3. Enter a name for the XML file.

4. Click Save.

Import Permission Groups
You can import permission groups from another project or from an XML file that you have exported from a project.

To import permission groups

1. In Manager (page 2), choose General > User Permissions (page 38) to open the User Permissions window.

2. Click Import to open a File Browser.
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3. Select a project file (*.PRO) or XML file (*.XML).

4. Click Open.

Delete Permission Groups
To delete a permission group

1. In Manager (page 2), choose General > User Permissions (page 38) to open the User Permissions window.

2. Under Permissions Groups, select the permission group you want to delete.

3. Click Del.

Licenses
ShipConstructor is a suite of software modules that you can purchase separately. When you purchase a module, you 
purchase a license to use that module. In addition, when you purchase a module, you purchase it at one of several levels
(Level 1, Level 2, and so on). Lower levels let you work with fewer parts per project, and higher levels let you work with 
greater numbers of parts per project. (For more information on ShipConstructor modules and licensing, visit 
www.ShipConstructor.com.)

When you purchase ShipConstructor, you receive a hardware lock that contains your particular license information. A 
hardware lock is a small device that you plug into the USB port of your computer. There are two types of hardware locks: 
local locks and network locks. A local lock must be installed on the same computer that is running ShipConstructor; only 
the user at that computer can access the licenses on the local lock. A network lock can be installed on any network 
computer; any ShipConstructor user on the network can access the licenses on the network lock, allowing users to time-
share licenses. (See the Installation Guide for more information on hardware locks.)

Users can check out a license (from a list of available licenses) from the Licensing window. (The Licensing window 
appears, by default, when a user starts ShipConstructor. You can also open the Licensing window by choosing 
ShipConstructor > Licensing.) Once all licenses have been checked out, no other users can use that module until a license 
is released. (The system administrator can release checked out licenses, making them available for other users.)

License Service
The License Service is a Windows service called ShipConstructor License Server that lets ShipConstructor communicate 
with hardware locks. The License Service is automatically installed with ShipConstructor.

License Monitor
The License Monitor is a utility that lets you list license information. See License Monitor (page 41).

Change the License Service Port
By default, the License Service uses port 3960 for communication. If there are other applications installed on your 
network that use port 3960, you must change the License Service port to avoid any conflicts. Otherwise, leave the 
License Service port set to 3960.

To change the license service port

Important: You must perform this procedure on all computers that have ShipConstructor installed.

1. Open the file C:\Program Files\ShipConstructor 2011\ShipConstructor\Server.Config using Notepad or another text 
editor.

2. Edit <Port>3960</Port>to change the port setting.
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3. Save the Server.Config file and close it.

4. In ShipConstructor, choose ShipConstructor > Licensing to open the Licensing window.

5. Click Network to open the Network License Settings window.

6. Change the Port setting to match the port setting you entered in Step 2.

7. Click OK to close the Network License Settings window.

8. Click OK to close the Licensing window.

9. Choose Start > All Programs > ShipConstructor2011 > Utilities > License Monitor to open the License Monitor.

10. Change the Port setting to match the port setting you entered in Step 2.

11. Click Connect.

12. Close the Licensing Monitor.

Note: Whenever you edit the Server.Config file, you must restart the License Service (see Restart the License Service
(page 25)).

Restart the License Service
To restart the license service

1. Choose Start > Control Panel to open the Control Panel.

2. Double-click Administrative Tools.

3. Double-click Services to open the Services window.

4. Right-click on ShipConstructor License Server and choose Restart.

List Available Licenses
To list available licenses

1. Choose Start > All Programs > ShipConstructor2011 > Utilities > License Monitor to open the License Monitor (page 
41).

2. Set Server to the IP address or computer name of the license server to connect to and set the Port to the port 
number.

Note: The default port number is 3960. See also Change the License Service Port (page 24).

3. Click Connect.

The License Monitor displays a list of modules and user information for the selected license server.
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Interface for LicenseMonitor

Server – The computer name or IP address of the license server.

Port – The TCP port to communicate with the license server. You should not have to change this from the default 3960.

Refresh – Connects to the server and receives and displays the results from the server’s response.

Locks Attached to Server – the list of ShipConstructor locks attached to the server computer. This will also show server 
connection errors. The Subscription Date column indicates the date when the Subscription date of the lock expires. This 
means that software that has a release date past this date will not be able to use a license from this lock. The Release 
date is shown the License window in ShipConstructor.

Licensed Module List – The list of modules that are currently hosted by the server specified. If there are multiple locks 
attached to the computer and a module is licensed on both locks then multiple instances of the same module will be 
listed separately.

Module Users – The list of users that currently have a license for the selected module.

Password – The authorization password that matches the password setup on the server

Release – Sends a release license request to the server. If successful then releases the selected module checked out by 
the selected user. The entered password must match the one configured on the server.

Release a license from a User
Sometimes it is necessary to release a specific license from a user.

To release a license

1. View the licenses.
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2. Select the module to release in the Licensed Module List.

3. Select the user in the User List.

4. Enter the password in the Password field.

5. Click Release. The user that had their license released will be informed of the released by a message. This message 
may take a few minutes before the license is released and the user still has the capability to reacquire the license.

Set a Release Password
The releasing of licensing can be setup to be password protected so only authorized people have permission to release 
user licenses.

To set a release password

1. On the license server computer open the file C:\Program Files\Common Files\SSI\SCLicensing\Server.Config in 
Notepad or other text editor.

2. Add the highlighted line similar to the following where yourpassword is the password.
<?xml version="1.0" encoding="utf-8" ?> 
<ServerSettings>

<Port>3960</Port>
<ReleasePassword>yourpassword</ReleasePassword>

</ServerSettings>

3. Save the file.
4. Restart the computer or restart the ShipConstructor License Server service from Control Panel > 

Administrative Tools > Services. Warning: This will causes users with licenses checked out to lose their 
licenses.

To Enable a Logging of License Counts
License counting is useful in determining if you need more or less licenses in a network license environment. The log file 
(C:\Program Files\Common Files\SSI\SCLicensing\LicenseStatistics.txt) is appended to at a specified interval.

5. On the license server computer open the file C:\Program Files\Common 
Files\SSI\SCLicensing\LoggingStatus.Config in Notepad or other text editor.

6. Add the three highlighted lines similar to the following.
<?xml version="1.0" encoding="utf-8" ?>
<LoggingStatus>

<LoggingEnabled>2</LoggingEnabled>
<FileSize>5000000</FileSize>

<StatisticsEnabled>1</StatisticsEnabled>
<StatisticsInterval>60</StatisticsInterval>
<StatisticsMaximumFileSize>5000000</StatisticsMaximumFileSize>

</LoggingStatus>
StatisticsEnabled – 1 = Enabled, 0 – disabled

StatisticsInterval – The time in seconds to add an entry in the log

StatisticsMaximumFileSize – Maximum size of the log file before it is deleted.

7. Save the file.
8. Restart the computer or restart the ShipConstructor License Server service from Control Panel > 

Administrative Tools > Services. Warning: This will causes users with licenses checked out to lose their 
licenses.
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Edit License Servers List from Older Software
In order to support User Account Control (UAC) in Windows Vista and Windows 7, licensing will save the license server list 
only for the currently logged on user. Older versions of ShipConstructor will potentially show a misleading license server 
list because they are looking in another save location. To be able to access the new location we have provided a new 
program SConLicenseListEditor to manage the correct license server list.

SConLicenseListEditor
A utility program to edit the license server list for the current user from outside ShipConstructor.

To setup a license server list for all users on the computer
The license server list will be filled from the Current User area of the registry. If no entries exist then the program will look 
in Local Machine. This gives administrators the capability to configure the license server list for all users on the computer.

Warning!: "Using Registry Editor incorrectly can cause serious, system-wide problems that may require you to re-
install Windows to correct them. Microsoft cannot guarantee that any problems resulting from the use of Registry 
Editor can be solved. Use this tool at your own risk."

Add the Strings using the registry editor.

Or create a REG file like the following and merge that into the registry of the computer.
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Project Settings & Libraries
There are certain settings that ShipConstructor uses throughout a project. Before you begin work on a project, you must 
set these project settings. You can also import project settings from another project or from an XML file that you have 
exported from another project.

Each project also contains various libraries defining the stocks, materials, and so on that you can use in the project. 
Before you begin work on a project, you must set up these project libraries.

• See the Structure manual for details on setting up general libraries and structure libraries.

• See the Pipe manual for details on setting up pipe libraries.

• See the Equipment and Penetrations manual for details on setting up equipment libraries and penetration 
standards.

• See the HVAC manual for details on setting up HVAC libraries.

You can also import project libraries from another project or from an XML file that you have exported from another 
project.

Set Project Settings
To set project settings

1. Choose ShipConstructor > Manager to open Manager (page 2).

2. Choose General > Project Settings (page 37) to open the Project Settings window.

3. Set the options (see Project Settings in the Structure manual for details).

4. Click OK to close the Project Settings window.

Import Project Settings
To import project settings

1. Choose ShipConstructor > Manager to open Manager (page 2).

2. Choose General > Project Settings (page 37) to open the Project Settings window.

3. Click Import to open a File Browser.

4. Select a project file (*.PRO) or XML file (*.XML).

5. Click Open.

Export Project Settings
To export project settings

1. Choose ShipConstructor > Manager to open Manager (page 2).

2. Choose General > Project Settings (page 37) to open the Project Settings window.

3. Click Export XML to open a File Browser.

4. Enter a name for the XML file.

5. Click Save.
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Import Project Libraries
To import project libraries

1. Choose ShipConstructor > Manager to open Manager (page 2).

2. Choose an option from File > Import Stocks (page 37) to open a File Browser.

3. Select a project file (*.PRO) or XML file (*.XML).

4. Click Open.

Export Project Libraries
To export project libraries

1. Choose ShipConstructor > Manager to open Manager (page 2).

2. Choose an option from File > Export Stocks (page 37) to open a File Browser.

3. Enter a name for the XML file.

4. Click Save.

Appendix: Menus, Tools & Commands

ShipConstructor Menu
See the Structure manual for details on other ShipConstructor menu items.

ShipConstructor > Project > New Project

Menu ............... ShipConstructor > Project > New Project
Toolbar............ None
Navigator ........ None
Command ...... SCNEWPROJECT
Permissions ... Admin User
Procedure....... Create A Project (page 3)

Creates a new project.

ShipConstructor > Project > Copy Project

Menu ............... ShipConstructor > Project > Copy Project
Toolbar............ None
Navigator ........ None
Command ...... SCCOPYPROJECT
Permissions ... Admin User
Procedure....... Copy A Project (page 5)

Copies a project (including all of its stocks and drawings).
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Copy Project Window

Project File
The project file you want to copy.

Project Name
The name you want to save the copied ShipConstructor project as.

Folder
The location you want to save the copied ShipConstructor project to.

Username
A username with administrative privileges.

Password
Your Admin password.

Administrator Menu
Administrator is a stand-alone utility that lets you set up and manage projects.

Project Name
The name of each project.

Version
The version number of the project database. See Update a Project Database Version (page 11) for details.

Size (MB)
The size of the project database (in megabytes).

Project GUID
The project’s ID number. Each project has a unique Project GUID.

Next Scheduled Backup
The date and time of the next scheduled backup. See Set Up Scheduled (Automatic) Project Backups (page 8) (page 8)
for details.

Note: This feature is not available on SQL Express servers.
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Server Menu

Server > Connect

Menu ............... Server > Connect
Toolbar............ None
Procedure....... Connect Administrator to a server (page 2)

Opens the Select Database Server window, letting you select the server for the projects you want to administer.

Server > Disconnect

Menu ............... Server > Disconnect
Toolbar............ None
Procedure....... Disconnect Administrator from the current server (page 2)

Closes the connection between Administrator and the current server.

Server > Refresh Project List

Menu ............... Server > Refresh Project List

Toolbar............
Procedure....... Refresh the Project List in Administrator (page 2)

Refreshes the list of projects in Administrator.

Server > Show All Databases

Menu ............... Server > Refresh Project List
Toolbar............ None
Procedure....... None

This option toggles whether the project list displays non-ShipConstructor databases.  Only a limited subset of commands 
is available for non-ShipConstructor databases.

Database Menu

Database > Copy

Menu ............... Database > Copy

Toolbar............
Right-click ...... Copy
Procedure....... Copy a Project (page 5)

Creates a new project that is an exact copy of the selected project but with a unique Project GUID.

Database > Delete

Menu ............... Database > Delete

Toolbar............
Right-click ...... Delete
Procedure....... Delete a Project (page 7)

Deletes the selected project.
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Database > Backup

Menu ............... Database > Backup

Toolbar............
Right-click ...... Backup
Procedure....... Manually Back Up a Project (page 8)

Creates a backup of the selected project.

Database > Restore

Menu ............... Database > Restore

Toolbar............
Right-click ...... Restore
Procedure....... Restore a Project Backup (page 10)

Restores a backed up project.

Database > Update

Menu ............... Database > Update

Toolbar............
Right-click ...... Update
Procedure....... Update a Project Database Version (page 11)

Updates the database version of the selected project.

Database > Execute SQL

Menu ............... Database > Execute SQL

Toolbar............
Right-click ...... Execute SQL
Procedure....... Execute SQL (page 11)

Lets you execute an SQL script file against the selected project.

Database > Check Project

Menu ............... Database > Check Project

Toolbar............
Right-click ...... Check Project
Procedure....... Check Project (page 11)

Analyzes your project database for inconsistencies.

Database > Repair Project

Menu ............... Database > Check Project

Toolbar............
Right-click ...... Repair Project
Procedure....... Repair Project (page 12)

This command is able to repair many inconsistencies reported by Check Project (page 11).
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Database > Schedule Backup

Menu ............... Database > Schedule Backup

Toolbar............
Right-click ...... Schedule Backup
Procedure....... Set Up Scheduled (Automatic) Project Backups (page 8)

Lets you set up a scheduled (automatic) backup of the selected project.

Database > Schedule Maintenance

Menu ............... Database > Schedule Maintenance
Right-click ...... Schedule Maintenance
Procedure....... Set Up Scheduled (Automatic) Project Maintenance (page 12)

Lets you set up a scheduled (automatic) maintenance of the selected project.

Database > Run Maintenance

Menu ............... Database > Run Maintenance

Toolbar............
Right-click ...... Run Maintenance
Procedure....... Manual Maintenance (page 12)

Performs maintenance on the selected project.

Database > Show Connected Processes

Menu ............... Database > Show Connected Processes
Toolbar............ None
Right-click ...... Show Connected Processes
Procedure....... Monitor Project Activity (page 7)

Displays active user connections to the project database.

Database > Synchronize Server Logins

Menu ............... Database > Synchronize Server Logins
Toolbar............ None
Right-click ...... Synchronize Server Logins
Procedure....... Synchronize Server Logins (page 14)

This will recreate any missing SQL server logins for all users in the selected database. The password for any logins 
created will be set to ShipCon.

Database > Unlock

Menu ............... Database > Unlock
Toolbar............ None
Right-click ...... Unlock
Procedure....... Unlock Database (page 14)

This will unlock the project database, so that uses may connect and use the project.
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Tools Menu

Tools > Manage Users

Menu ............... Tools > Manage Users

Toolbar............
Right-click ...... Manage Users
Procedure....... User Accounts (page 19)

Opens the Manage Users window, letting you create and edit user accounts.

ShipConstructor Users
Lists all ShipConstructor user accounts and which projects each user account has access to. DB Admin indicates user 
accounts with system administrator privileges.

Change Password
Lets you change the password for the selected user account.

New User
Creates a new user account.

Copy User
Creates a new user account that has access to the same projects as the selected user account.

Delete User
Deletes the selected user account.

Tools > Add Database from Backup

Menu ............... Tools > Add Database from Backup

Toolbar............
Procedure....... Add Database from Backup (page 10)

This creates a new database on the server from a backup file.

Tools > Change ShipConstructor User Password

Menu ............... Tools > Change ShipConstructor User Password
Toolbar............ None
Procedure....... Change the System Password (page 21)

Lets you change the system password (the password of the ShipConstructor user account).

Tools > Re-Attach Database

Menu ............... Tools > Re-Attach Database
Toolbar............ None
Procedure....... Re-attach a Project Database to Server (page 14)

Lets you re-attach a detached project to its server.

About Menu

About > About Administrator
Displays the Administrator version number.
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Right-click Menu

Copy
See Database > Copy (page 32).

Delete
See Database > Delete (page 32).

Backup
See Database > Backup (page 33).

Restore
See Database > Restore (page 33).

Update
See Database > Update (page 33).

Execute SQL
See Database > Execute SQL (page 33).

Check Project
See Database > Check Project (page 33).

Repair Project
See Database > Repair Project (page 33).

Schedule Backup
See Database > Schedule Backup (page 34).

Schedule Maintenance
See Database > Schedule Maintenance (page 34).

Run Maintenance
See Database > Run Maintenance (page 34).

Show Connected Processes
See Database > Show Connected Processes (page 34).

Synchronize Server Logins
See Database > Synchronize Server Logins (page 34).

Unlock
See Database > Unlock (page 34).

Toolbar
Refresh Project List – See Refresh the Project List in Administrator (page 2).

Manage Logins – See User Accounts (page 19).

Add Database from Backup – See Add Database from Backup (page 10).

Copy Database – See Copy a Project (page 5).

Delete Database – See Delete a Project (page 7).

Backup Database – See Back Up a Project (page 8).

Restore Database From Backup – See Restore a Project Backup (page 10).

Update Database – See Update a Project Database Version (page 11).
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Run Maintenance – See Manual Maintenance (page 12).

Execute SQL – See Execute SQL (page 11).

Check Project – See Check Project (page 11).

Schedule Database Backups – See Set Up Scheduled (Automatic) Project Backups (page 8).

Schedule Maintenance – See Set Up Scheduled (Automatic) Project Maintenance (page 12).

Manager Menu
Manager is a utility that lets you set up project settings, project libraries, and user permissions.

File > Import Stocks

Menu ............... File > Import Stocks
Toolbar............ None
Permissions ... The ability to edit the type of stock being imported
Procedure....... Import Project Libraries (page 30)

Lets you import Manager settings from another project or from an XML file that was exported from another project either 
for All Modules or for an individual menu in Manager (General, Structure, Pipe, HVAC, or Equipment).

File > Export Stocks

Menu ............... File > Export Stocks
Toolbar............ None
Permissions ... None
Procedure....... Export Project Libraries (page 30)

Exports Manager settings to an XML file either for All Modules or for an individual menu in Manager (General, Structure, 
Pipe, HVAC, and Equipment).

File > Exit
Closes Manager.

General > Project Settings

Menu ............... General > Project Settings

Toolbar............
Navigator ........ Settings (with the project selected)
Permissions ... None
Procedure....... Set Project Settings (page 29)

Opens the Project Settings window, letting you set various project-wide settings.

Reports
See the Structure manual for details.

General
See the Structure manual for details.
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Structure
See the Structure manual for details.

Common Parts Catalog
See the Structure manual for details.

Pipe
See the Pipe manual for details.

HVAC
See the HVAC manual for details.

Hull
See the Hull manual for details.

General > User Permissions

Menu ............... General > User Permissions

Toolbar............
Navigator ........ User Permissions (with the project selected)
Permissions ... Manager > User Permissions
Procedure....... User Permissions (page 22)

Opens the User Permissions window, letting you set up user permissions and permission groups.

Users
Lists all users for the current project. Select a user to display their user permissions under User Overrides.

Permission Groups
Lists all permission groups for the current project. Check a check box to include the selected user in the permission 
group.

Edit
Opens the Edit Permission Group window for the selected permission group, letting you set the permissions for the group.

New
Creates a new permission group.

Del
Deletes the selected permission group.

Import
Lets you import permission groups from another project or from an XML file that was exported from another project.

Export XML
Exports permission groups to an XML file.

User Overrides
Displays and lets you edit the permissions for the selected user.

General > Materials
Opens the Materials window, letting you create and edit materials. See Materials in the Structure manual for details.

General > Manufacturers
Opens the Manufacturers window, letting you create and edit manufacturers. See Manufacturers in the Structure manual 
for details.
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General > Finishes
Opens the Finishes window, letting you create and edit finishes. See Finishes in the Structure manual for details.

General > Insulations
Opens the Insulation window, letting you create and edit insulation. See Insulation in the HVAC manual for details.

General > Text Styles
Opens the Text Styles window, letting you create and edit text styles. See Text Styles in the Structure manual for details.

General > Accessory Packages
Opens the Accessory Packages window, letting you create and edit accessory packages. See Accessory Packages in the 
Pipe manual for details.

General > Naming Conventions
Opens the Naming Conventions window, letting you create and edit naming conventions. See Naming Conventions in the 
Structure manual for details.

General > Production Output > Label Styles
Opens the Label Styles window, letting you create and edit label styles. See Label Styles in the Structure manual for 
details.

General > Production Output > Dimension Styles
Opens the Dimension Styles window, letting you create and edit dimension styles. See Dimension Styles in the Structure
manual for details.

General > Production Output > Bill of Materials
Opens the Bill of Materials window, letting you edit BOM definitions for the various disciplines. See Bill of Materials in the 
Structure manual for details.

General > Production Output > Predefined Assembly Format
Opens the Predefined Assembly Format window, letting you edit settings related to assemblies. See Predefined Assembly 
Format in the Structure manual for details.

Structure > Stock Catalog
Opens the Structural Stock Editor window, letting you create and edit structural stocks. See Stocks in the Structure
manual for details.

Structure > Piecemark Styles
Opens the Piecemark Styles window, letting you create and edit piecemark styles. See Piecemark Styles in the Structure
manual for details.

Structure > User-Defined Attributes
Opens the User-Defined Attributes window, letting you create and edit user-defined attributes for structural parts and 
stocks. See User-Defined Attributes in the Structure manual for details.

Structure > Plates > Orientation Icon
Opens the Orientation Icon window, letting you create and edit orientation icons. See Orientation Icon in the Structure
manual for details.
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Structure > Plates > Markline Styles
Opens the Markline Styles window, letting you create and edit markline styles. See Markline Styles in the Structure
manual for details.

Structure > Plates > Flange Catalog
Opens the Flange Library window, letting you create and edit plate flanges. See Flanges in the Structure manual for 
details.

Structure > Plates > Corner Treatments
Opens the Corner Treatments window, letting you create and edit corner treatments. See Corner Treatments in the 
Structure manual for details.

Structure > Plates > Green Standards
Opens the Green Standards window, letting you create and edit green standards. See Green Standards in the Structure
manual for details.

Structure > Plates > Bevel Standards
Opens the Bevel Standards window, letting you create and edit bevel standards. See Bevel Standards in the Structure
manual for details.

Structure > Plates > NC Machines
Opens the NC Machines window, letting you create and edit NC machines. See NC Machines in the Structure manual for 
details.

Structure > Extrusions > Endcut Catalog
Opens the Endcut Definitions window, letting you create and edit profile stock endcuts. See Endcuts in the Structure
manual for details.

Structure > Extrusions > Green Standards
Opens the Green Standards window, letting you create and edit green standards. See Green Standards in the Structure
manual for details.

Structure > Standard Parts
Opens the Standard Parts window, letting you create and edit standard (structural) parts. See Standard Parts in the 
Structure manual for details.

Piping > Stock Catalog
Opens the Pipe Stock Catalog, letting you create and edit pipe library items. See the Pipe manual for details.

Piping > Pipe Benders
Opens the Pipe Bending Machines window, letting you create and edit pipe bending machines. See Pipe Bending 
Machines in the Pipe manual for details.

Piping > User-Defined Attributes
Opens the User-Defined Attributes window, letting you create and edit user-defined attributes for pipe parts and stocks. 
See User-Defined Attributes in the Structure manual for details.

HVAC > Stock Catalog
Opens the HVAC Catalog Stock Editor, letting you create and edit end treatments, HVAC stocks, catalogs, specs, and 
connections. See the HVAC manual for details.
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HVAC > Sheet Stocks
Opens the Sheet Stocks window, letting you create and edit sheet stocks. See Sheet Stocks in the HVAC manual for 
details.

HVAC > User-Defined Attributes
Opens the User-Defined Attributes window, letting you create and edit user-defined attributes for HVAC parts and stocks. 
See User-Defined Attributes in the Structure manual for details.

Electrical > Cable Library
Opens the Cable Stock Library window, letting you create and edit cable stocks. See the Electrical manual for more 
details.

Electrical > Cable Support Library
Opens the Cable Support Library window, letting you create and edit cable support stocks. See the Electrical manual for 
more details.

Equipment > Equipment Library Editor
Opens the Equipment Library Editor, letting you create and edit equipment items. See the Equipment and Penetrations
manual for details.

Penetrations > Standards
Opens the Penetration Standard Editor, letting you create and edit penetration standards. See the Equipment and 
Penetrations manual for details.

Database Utilities > Raw Data

Menu ............... Database Utilities > Raw Data
Toolbar............ None
Permissions ... Manager > Edit Raw Data
Procedure....... View Project Database Raw Data (page 14)

Opens the Database Raw Data window, letting you display and edit the raw data contained in the project database.

Window >
Lets you switch between open windows in Manager.

Note: If no windows are open, the Window menu is empty.

License Monitor
The License Monitor is a utility that lets you list license information and release licenses that are checked-out. See 
Licenses (page 24).
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Server
Enter the IP address or computer name of the license server you want to monitor.

Port
Enter the port number of the license server you want to manage.

Connect
Connects the License Monitor to the license server specified by IP or \\domain\computer and Port. It changes to Refresh
after the Monitor is connected.

Refresh
Refreshes the information in the License Monitor by re-connecting with the license server. You will need to refresh the 
information if the lock configuration on the server is changed or users have checked out licenses.

Locks Attached to Server
Lists all the ShipConstructor locks attached to the computer and when they will expire.

Licensed Module List
Lists license information for the selected license server. See List Available Licenses (page 25).
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